Microsoft Excel
Hints, Tips and Tricks
How do I hide certain rows or columns of my excel sheet?
Select the row/column(s) you wish to hide. Right-click on the same and select Hide.
In case you wish to "unhide" these row/column(s) later, select the adjoining
row/column(s), right-click and select Unhide.
How do I select cells around the hidden cells without including the hidden cells?
Select the range, including the hidden cells. Just press <Alt>.
The hidden cells will be EXCLUDED from the selection!
How do I print my Excel files in Color? Whenever I print, the color markings get
printed in Black and White!
1. Go to Page Setup in the File Menu.
2. Click the Sheet tab.
3. Under Print, deselect Black and White.
4. Click OK and Save the worksheet.
From now on, Excel will print this sheet with the colors you have used.
Did you know there is a hidden simulation "game" in Excel 97?
Here's how you see it:
1. Open MS Excel.
2. Press <F5>.
3. Enter x97.l97.
4. Press <Enter>.
5. Press <Tab>.
6. Press <Ctrl><Shift> and with mouse press chart icon on the toolbar. On you go!
Play a simulation game.
(The programmers' names come somewhere but be careful as they scroll too fast)
How do you insert date in Excel?
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Select a cell and Press <Ctrl>semicolon key.
How do you insert time on your excel spread sheet?
Select the cell and Press <Ctrl><Shift>semicolon key.
How do you remove gridlines for the entire excel worksheet?
1. Go to “Tools” menu.
2. Click on “Options”.
3. Click on the “View” tab.
4. Uncheck the “Gridlines” box.
How to print gridlines in your Microsoft Excel worksheet?
1. Go to “File” menu and click on “Page Setup”.
2. Click on “Sheet” tab.
3. Check “Gridlines” box under “Print” topic.
How do you increase rows on your worksheet?
1. Go to “Format” menu.
2. Click on “Row”.
3. Click on “Height”.
4. Increase the Row Height.
5. Click on OK.
How can I increase the width of my worksheet columns?
1. Go to “Format” menu.
2. Click on “Column”.
3. Click on “Width”.
4. Increase the Column Width.
5. Click on OK.
How can I go to the end of my worksheet quickly?
Press <Ctrl><down arrow>.
How can I draw a line in a graph in Excel?
You can draw a line in a graph in Excel by following the steps given below:
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1. If drawing toolbar is not visible, click View --> Toolbars --> Drawing.
2. Click on the "line" icon from the drawing tool bar.
3. Now, draw a line in the chart by clicking on it and dragging.
How can I change the default font?
Excel's standard font is 10-point Arial. If you want to specify a font for all new
worksheets, you can change the default font.
1. Open the Tools menu and select Options.
2. Click on the General tab and choose a new font from the Standard Font
dropdown list. You can also specify a size.
3. Click on OK to close the dialog box, and then click on OK at the message box.
You will have to exit and restart Excel to make the change permanent
Use AutoFill to Quickly Copy Formulas and Formatting in Excel
Would you like an easy way to extend a series of numbers in Microsoft Excel without
typing each one individually? With AutoFill, you can quickly copy data, formulas, or
formatting to adjacent cells. This brief tutorial will show you how:
1. Select the cells that you would like to copy.
2. Move the cursor to the bottom right corner of the highlighted cells. Your cursor
will then turn into a black plus sign.
3. Click and hold down the right mouse button and drag across the cells you want to
fill.
4. Release the mouse button, and when the shortcut menu appears, click Fill Series.
By following these steps, you will be able to save a lot of time creating your
spreadsheets.
Show or Hide the Formulas in an Excel Spreadsheet
When you're working in an Excel worksheet, you can alternate between viewing the
values in the cells and displaying the formulas. To toggle between the different views,
press <Ctrl>` (single left quotation mark).
Note: If you're having trouble finding the single left quotation mark, it's on the same key
as the "~" symbol. On most keyboards, it's the key directly to the left of the "1" key.
Don't Lose Sight of Your Column Headings in Excel
Would you like to see the column headings on your Microsoft Excel spreadsheets no
matter how far down you scroll? Here is one way to keep the column headings
constantly visible:
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1.
2.

Select the row just below your column headings.
On the Window menu, click Freeze Panes.

The "frozen" column headings don't scroll, but remain visible as you move through the
rest of the worksheet.
Edit Cells Quickly in Excel—Without Using Your Mouse
If you like to use your keyboard for everything, editing a lot of data quickly in an Excel
spreadsheet can be difficult because you find yourself constantly reaching for the mouse
when you want to make changes to a cell. But there's a shortcut you can use so that your
hands never have to leave the keyboard—press <F2>. Here's how:
1. Use the arrow keys to select the cell you want to edit.
2. Then press <F2> (or COMMAND-U, if you use a Macintosh computer) to edit
the cell contents.
3. When you're finished, just press <Enter> (or RETURN on a Macintosh
keyboard) to enter your changes. Or press <Esc> to cancel the changes.
Note: This tip is especially handy for editing hyperlinks in Excel because, if you use your
mouse to click on a cell with a hyperlink, it automatically opens an Internet browser
window. Using the keyboard lets you edit hyperlinks with ease.
Create an Excel Chart with the Push of a Button
This is a very old Microsoft Excel trick. To quickly create a chart, using only your
keyboard, select the data you want to plot and then press <F11>. Excel automatically
creates the chart for you.
Note: Another way to do this trick is after you select your cells, press <Alt><F1> and
you'll get the same result.
Select an Entire Range of Cells in Excel
In Excel, if you want to quickly select the entire range of cells you're working on, press
<Ctrl><Shift>* (asterisk).
For example, if you have a list of customers in Excel, this command will select the entire
list and the column headings, but not the empty cells around the list—so you get only the
cells you need.
This tip is different from the Select All command, which selects every cell in the
worksheet—even the ones that you are not using.
Insert Copied Cells Between Existing Cells Safely
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If you want to insert a range of copied cells between other rows or columns—instead of
pasting over them—there's an easy way to do it:
1.
2.
3.
4.
5.

Select the cells you want to copy.
On the Edit menu, click Copy.
Select the area on the worksheet where you want to place the copied cells.
Press <Ctrl><Shift>+ (Plus Sign).
In the Insert dialog box, click the direction you want to shift the surrounding
cells, and press OK.

Now, the copied cells are inserted right where you want them, and none of your existing
information is lost.
Build Vertical Titles in Excel
Have you ever wondered how to create a heading for a table that runs vertically along the
side of a table instead of above it?
Here's how I do it:
1. Select the cell that contains your text as well as the surrounding cells that you
want your title to span.
2. On the Format menu, click Cells, and then click the Alignment tab.
3. In the degrees text box, enter 90.
4. Select the Merge cells text box and click OK.
Format Excel Cells Fast
If you want quick access to the Format Cells dialog box in Microsoft Excel to change
things like type style, alignment, or borders, select the cell you want to format and press
<Ctrl>1.
Have Excel Save Your Files Automatically
Have you ever wanted Excel to automatically save your spreadsheets for you so you don't
lose your work? Excel 2000 includes a feature that saves workbooks automatically at
specified intervals, but it's not installed by default. Here's how you can install and use the
Autosave Add-in:
First you need to load the add-in, which will add it to your Tools menu:
1. On the Tools menu, click Add-Ins.
2. In the Add-Ins available list, select the Autosave Add-in check box and then
click OK.
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(Note: If the Autosave Add-in is not available, you may need to install it. For more
instructions, search for the phrase "Install or remove individual features of Microsoft
Office or Excel" in Excel 2000 Help.)
Then, to configure and use the Autosave feature:
1.
2.
3.
4.

On the Tools menu, click AutoSave.
Select the Automatic save every check box.
In the Minutes box, enter how often you want Excel to save your workbooks.
Select any other options you want, and press OK.

Quickly Move Between Multiple Excel Workbooks or Worksheets
When working with several Excel workbooks or worksheets (the individual pages in
workbooks) at once, you can quickly move between them using shortcut keys.
•
•
•

To move between open workbooks, press <Ctrl><Tab>.
To move to the next sheet in a workbook, press <Ctrl><Page Down>.
To move to the previous sheet in a workbook, press <Ctrl><Page Up>.

Do Fast Calculations in Excel
Have you ever needed to know the largest value in a series of cells? You can create a
formula to do that, but there is a faster way.
To view the largest value in a series of cells:
1. Select the cells in which you are interested, and you will see the sum of the range
displayed on the status bar, which is the horizontal area below the worksheet
window.
2. If the status bar is not displayed, click Status Bar on the View menu.
3. Right-click the status bar, and then click Max. Now you can see the maximum
value displayed on the status bar.
You can use the same technique to find the average of, the sum of, or the minimum value
in the selected range. You can also count the cells that contain numbers (by selecting
Count Nums) or count the number of filled cells (by selecting Count).
Completely Delete Cells in Excel Using This Shortcut
Have you ever wanted a keyboard shortcut that completely deletes a cell from your
worksheet, including the formatting and comments? Just select the cells you want to
delete, and then press <Ctrl>– (minus sign). The surrounding cells will shift to fill the
space.
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This is different from using the <Delete> or <Backspace> keys, which simply clears the
contents of a cell without actually deleting it.
Copy the Contents of an Entire Worksheet in Excel
Here's a timesaving tip for Excel users who frequently need to copy an entire worksheet
(a page within a workbook) of information—such as a list of items for a monthly
inventory—from one workbook (Excel file) to another.
To copy an entire sheet to another workbook:
1. Open the workbook into which you want to paste the copied sheet.
2. Switch to the workbook that contains the sheet you want to copy.
3. Right-click the Sheet tab of the sheet you want to copy, and then click Move or
Copy on the shortcut menu.
4. From the To book drop-down menu, select the workbook that will receive the
sheet. (To copy the selected sheet to a new workbook, click New book on the
drop-down menu.)
5. Select the Create a copy check box. (If you don't select this check box, the sheet
will be moved instead of copied.)
6. Click OK.
Do Creative Calculations with Paste Special
I find this trick fantastically useful. If you have a block of numeric data in an Excel
worksheet and you wish to change each entry to a negative value, use Paste Special with
a twist.
Here's how:
1.
2.
3.
4.
5.
6.

In an empty cell, type -1.
Select the cell, and click Copy on the Edit menu.
Now select the cells containing the values you want to change.
On the Edit menu, click Paste Special.
Under Paste, click Values and under Operation, click Multiply.
Click OK.

All the numbers change from positive to negative, or vice versa. This method is also
useful for reducing numbers by a factor of 1,000, 1,000,000, and so on.
Quickly View All Worksheet Formulas in Excel
With a quick keystroke, you can display all the formulas in your worksheet, including the
serial values Excel uses to store dates.
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To alternate between displaying cell values and displaying cell formulas, press <Ctrl>`
(single left quotation mark, which usually can be found above the <Tab> key).
Add a Calculator to the Excel Toolbar
Did you know that you could add a calculator to your Microsoft Excel toolbar? Here's
how:
1. On the View menu, click Toolbars, and then click Customize.
2. Click the Commands tab.
3. In the Categories list, click Tools, and in the Commands list, click Custom (the
one with the gray calculator graphic).
4. Drag the selected command from the Commands list to a toolbar. (Lift your finger
from the mouse when you see a plus sign next to your pointer.)
5. Click Close.
Now click the button you just added to run the calculator.
Paste Information from Excel as a Picture
Do you want to place an image of an Excel file into a Word document, image editing
program, or other program? It's easy to do.
1. On the Excel worksheet or chart sheet, select the cells or click the chart or object
you want to copy.
2. Hold down <Shift> and click Copy Picture on the Edit menu.
3. For best picture quality, make sure As shown on screen and Picture are selected,
and then click OK.
4. Click the worksheet or other document where you want to paste the picture.
5. Click Paste on the Edit menu.
To make adjustments to the image after you've pasted it, use the Picture toolbar. (To open
it, point to Toolbars on the View menu and click Picture.)
Note: Cell gridlines appear in the picture if they are displayed. To omit gridlines, in
Excel click Options on the Tools menu, click the View tab, and then clear the Gridlines
check box.
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